The Edit Menu

Launch Delineator …

The delineator was originally intended for labelling landmarks on the texture map that could be used to align faces. It can still be used to help with this (the 2D points can be mapped to 3D) or can be used to view the texture map, for example after performing one of the flattening operations. The File menu on the delineator allows you to open or save a 2D template file (.tem). You can click and drag points in a 2d template, change the zoom, auto delineate and view the 2d template on the 3D surface using the options provided. To create a 3D template from the 2D points use the option on the Template menu of the main window.

Launch Preview

The Preview dialogue allows capture of multiple screenshots in a sequence. The start and end values for rotation angles about the main axes can be configured, the numbr of steps to capture and the time for the sequence. Clicking the OK button brings up a play button allowing you to see the animation sequence. Clicking Edit returns to the main dialogue. When you are happy with the preview tick the Save JPEGS" checkbox, and Browse to a suitable folder. Click OK and Play to generate the output. It is possible to save MPEG movies, but this requires Java Media Framework to be installed separately.

Remap Texture

The texture maps that come with certain file formats (e.g. .tsb files) are made from multiple images contained within a single texture map. This can cause problems for certain algorithms, and it is recommended that you remap the textures into a single image perform doing further processing. Textures can be remapped onto a square image of size 1024x1024 (the default) or a circle contained with an image of that size. It is recommended that you use the square remapping, the circle is provided for backwards compatibility and can be enabled by unchecking the "Remap to square" checkbox. You can view the resulting texture map using the delineator. There is also a batch option for remapping several textures in a single operation. This takes a text file listing the .obj files as a parameter.

Trim to mask

This option allows some simple mesh editing. It works with the delineator, you need to load a suitable 2D template into the delineator and adjust the points and lines to match the face. When you click "Trim to mask" it will prompt for a Mask file (.msk) which can be created in JPsychomorph. The masked areas will be removed from the mesh. An invert options is also provided that remove all points within the masked area, instead of those outside the mask area.

Normals and smoothing

The mesh can be smoothed using Edit->Smooth, which replaces each vertex by an area weighted sum of adjacent vertices. This can result in some shrinkage of the mesh around the edges (e.g. holes will get a little bigger). Normals should be recalculated after smoothing using the "Edit->Recalculate normals" option.

Rigid alignment options

A mesh can be rigid aligned to another mesh with the same mesh topology (i.e. number of vertices etc) using "Edit->Rigid body normalise", to a 3D template using Edit -> Rigid Body Normalise (T3D) or to a standard reference frame based on 3 points using oe of the Edit -> Orientate 3 points options. The first two will prompt for the mesh or template respectively. For the 3 point orientation the first 3 points of a 3D template will be used.

The "Orient 3 point" option uses the first point as the origin (0,0,0) the direction between the second and third points is constrained to lie in the x-z plane parallel to the x-axis. Typically point 0 is placed on the bridge of the nose between the eyes, points 1 and 2 are placed on the outer eye corners (outer lateral canthus).

The "Orient 3 point (Alternative)" option uses the midpoint of the first two points as the origin (0,0,0) the direction between the first and second points is constrained to lie in along the x-axis and the third point is constrained to lie in the x-z plane. Typically point 0 and 1 are placed in the ear holes (or some landmark nearby) and the third point is placed on the lowest point on the (left) eye orbit to establish the alignment to the Frankfort plane.

Warping options

Warp3D and Batch Warp3D warp using a combination of a 3D template file and alignment of automatically matched points along the surface normal directions. This is done in three stages , first the geometry of the standard surface is warped using the 3D template points, then the normals of the "standard" surface are traced and any intersections with the target surface (within a certain distance) are recorded, these matches are then used to drive a second warp of the surface. During the second warp the texture of the study surface is also warped in 2D into the 2D shape of the "standard" texture map.

The Warp3D (Template) and Warp3D TPS (Template) only perform the first part of this process (warping based on the 3D template points), one with a multi-level B-spline warping method and the other using thin-plate splines.

The Warp Reference option is for warping using a standard texture map that was needed in some recent work.