Autodelineation using ASMs

Psychomorph has a built in auto-delineation system using Active Shape Models. These shape models can be constructed from a set of pre-delineated images or a set can be downloaded from our website. Downloading and Installation. To install, unzip the ASM files into a new directory. Each ASM is composed of multiple files; all must be in the same directory in order to correctly function. Each ASM should be installed in a separate directory to avoid conflicts.

Single image

All these instructions pertain to the Transform window of the application:

  1. Load the image
  2. Load the ASM e.g. sci_mus.asm from the File menu
  3. Load a Template e.g. sci_mus.tem
  4. Click View->Display 3 Points
  5. Move the points onto the eyes and mouth
  6. Click Delineate->ASM->Auto Delineate, the template should generated and displayed
  7. Manually correct the template and save it.

For each subsequent image you should be able to skip 2 and 3, and there is also a batch method.

Batch Auto-delineation (multiple images)

All these instructions pertain to the Transform window of the application:

  1. Load the ASM e.g. sci_mus.asm from the File menu
  2. Load a Template e.g. sci_mus.tem
  3. Click Delineate -> ASM -> Batch auto delineate
  4. You are prompted for a "standard" list file, output folder and a string to append to the output file names.
  5. Each image will be loaded in turn with 3 points displayed.
  6. Move the points onto the eyes and mouth
  7. Click Next on the pop up window, the template should generated, displayed and saved then the next image loaded until done.