Tracking Image Sequences

The following is just a quick start guide. You will need a video clip converted to a series of images (e.g. jpg files) numbered in sequence from 0. You will also need a "standard" Template and a Mask file.

1. Select "File->Start Tracker" from the PsychoMorph window, this should bring up a new window "Tracker". Select "File->Load Images" from this window and choose the first image in the sequence using the file dialog. You should now be able to see the first frame of your sequence in the window, and click and drag the scroll bar to view different frames.

2. You can load a template into the window using "File Load Single Template". You can manually adapt a template to the face in the frame by first selecting "View->Three Points" and placing the eye and mouth points by clicking and dragging, then selecting "View->Template" and clicking and dragging individual points and lines.

3. Load and manually adapt the template to a number of "key" frames (including the first). Make sure you tick the "Fixed" checkbox in the bottom left hand corner for each frame that you manually delineate. For a quick test you could use as few as 3 frames, but more are required for a good tracking.

4. Load your Mask file using "PCA->Load Mask".

5. Select PCA->Rebuild Data", this builds a PCA shape and colour model using the frames you have ticked as fixed.

6. Select "Actions->Start Tracking", fingers crossed, and weight for the scroll bar to reach the right hand side.

7. Save the Templates using "File->Save Templates".

Good luck!